Maix Bit with OV2640



  • Hi !
    I am trying the Standalone demo - dvp2sdcard with a OV2640 connected to my Maix Bit Board. However, I am I get the following error :

    system start
    DVP init
    manuf_id:0xffff,device_id:0xffff
    

    My configuration for the code is

    #define  OV5640             0
    #define  OV2640             1
    
    #define  BOARD_KD233        1
    #define  BOARD_LICHEEDAN    0
    #define  BOARD_K61          0
    

    Is that right ?
    Can anyone describe a way to get it working ?

    Regards,
    pixelhaze



  • To answer my own question, the following setting works on Maix Bit:

    	#define  OV5640             0
    	#define  OV2640             1
    
    	#define  BOARD_KD233        0
    	#define  BOARD_LICHEEDAN    1
    	#define  BOARD_K61          0
    

    The output is as follows:

    	DVP init
    	manuf_id:0x7fa2,device_id:0x2642
    	DVP interrupt config
    	system start
    


  • To answer my own question, the following setting works on Maix Bit:

    	#define  OV5640             0
    	#define  OV2640             1
    
    	#define  BOARD_KD233        0
    	#define  BOARD_LICHEEDAN    1
    	#define  BOARD_K61          0
    

    The output is as follows:

    	DVP init
    	manuf_id:0x7fa2,device_id:0x2642
    	DVP interrupt config
    	system start
    


  • Follow up:

    I am able to see low res preview of 320x240 on MaixPyIDE using a python script.
    However, the dvp2sdcard example is still a challenge !