VisualGDB now supports the K210 Chip



  • Hi All,
    We just wanted to let everybody know that we have added support for the K210 chip to VisualGDB the Visual Studio extension for advanced cross-platform development. We have published a detailed tutorial on creating, building and debugging a K210-based project here: https://visualgdb.com/tutorials/risc-v/kendryte/k210/



  • @sysprogs this is great!

    I followed your instructions to build the gpio_led demo and it worked perfectly.

    I have not used Visual Studio prior to this so this is new to me. I followed the Kendryte tutorials for building a project which calls for having projects created under .\Kendryte-Standalone-SDK\src so the project source files are located within the SDK source tree. My understanding is that the normal/easy way of creating an embedded project with Visual Studio/GDB is to place the project source files in one location and reference the SDK dependencies in another location (done automagically by VS) so the Kendryte recommendation for setting up the project is at odds with the standard VS method. Your tutorial follows the VS approach.

    I created a project structure that I want to preserve as it will allows me to track changes to the orginal Kendryte SDK while making changes to it that are necessary for my project. To do this I copied the entire Kendryte-Standalone-SDK tree to a new location and renamed it to PROJECT_MCU and I have my project files (and some of the Kendryte demos) under src as recommended by Kendryte.

    Structured as follows:

    0_1566236411600_Folder Structure.jpg

    I figured out how to import an existing project into VS by following the tutorial >>> here <<< and the project builds fine with the output binary showing up where it should.

    When first run VS/GDB did not find the SDK source & header files but I was able to figure out how to include the folders to them so I got by that problem.

    However, I can't get by the following error even though it seems like an easy one to fix...

    No executable file specified. Use the "file" or "exec-file" command.

    I did specify the built binary as my output file and I tried changing settings under menu "Debug/{project} properties". I also went through all of the options under menu "Project/VisualGDB Project Properties" but nothing stood out. I really don't know what could be wrong. Can you provide a suggestion for resolving this?

    Thank you (in advance)


  • Staff

    Good job!
    Since threads posted in Annoucements category should be by stuff only, this thread is moved to General Discussion