WOW! Openocd as LDD!



  • Trying to run openocd from Kendryte IDE in debian 9 results in:

    [ INFO] start openocd server.
    [ INFO] config file write to: /home/asterion/KendryteIDE/LocalPackage/hello-world-project/src/.vscode/openocd.cfg
    [ INFO] finding port.
    [ INFO] port=35957
    [ INFO]  + /home/asterion/KendryteIDE/LocalPackage/openocd/openocd -f /home/asterion/KendryteIDE/LocalPackage/hello-world-project/src/.vscode/openocd.cfg
    [ INFO] OpenOCD process started. waiting for output...
    [ OCD] /home/asterion/KendryteIDE/LocalPackage/openocd/openocd: error while loading shared libraries: libftdi.so.1: cannot open shared object file: No such file or directory
    [  ERR] OpenOCD process exit with 127
    [  ERR] OpenOCD Command OpenOCD process died: 127
    

    Why was't libftdi.so installed by updater or IDE? What is going wrong with the installer?



  • @Asterion AND it appears you need libhidapi-hidraw.so.0.

    Again, FULL installation instructions and FULL running examples needed. This poor documentation and examples could kill off Kendryte. Spend some time on getting the development environment in a fit state strangers can use. I know it is fun you have a small group who "now" things but that doesn't pay the bills.



  • @Asterion Ah, @GongT meant libftdi1 (perhaps). Again, would help with full instructions to get IDE working.



  • Anyone know how to install libftdi? It isn't what @GongT suggested.



  • @GongT But you can provide a full instruction on how to install the IDE and all its dependencies. Where is that please? I assume libftdi is not the only thing you have left out. What other dependencies are there for full operation?


  • |  Mod

    We can't bundle a system library on linux, you must install it by yourself. (eg. apt install libftdi)